RSS

Problem z GDM podczas aktualizacji Ubuntu 9.10 alpha 6 do wersji beta

04 Paźdź

Jeżeli podczas aktualizacji U9.10 alpha 6 do beta napotkaliście na taki błąd :

Konfigurowanie gdm (2.28.0-0ubuntu12) ...
chown: nie ma dostępu do `/var/lib/gdm/.gvfs': Permission denied
dpkg: błąd przetwarzania gdm (--configure):
podproces installed post-installation script zwrócił kod błędu 1
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie indicator-session:
indicator-session zależy od gdm; jednakże:
Pakiet gdm nie jest jeszcze skonfigurowany.
dpkg: błąd przetwarzania indicator-session (--configure):
problemy z zależnościami - pozostawiony nieskonfigurowany
No apport report written because the error message indicates its a followup error from a previous failure.
Wystąpiły błędy podczas przetwarzania:
gdm
indicator-session

a polecenie ls -al dało taki wynik

# ls -al /var/lib/gdm/
ls: nie ma dostępu do /var/lib/gdm/.gvfs: Permission denied
razem 84
drwxrwxrwx 14 gdm gdm 4096 2009-10-04 11:14 .
drwxr-xr-x 60 root root 4096 2009-10-04 11:10 ..
drwx------ 2 gdm gdm 4096 2009-09-21 20:51 .cache
drwx------ 2 gdm gdm 4096 2009-09-20 21:05 .config
drwx------ 3 gdm gdm 4096 2009-09-20 21:05 .dbus
-rw------- 1 gdm gdm 16 2009-09-21 20:51 .esd_auth
drwxr-xr-x 2 gdm gdm 4096 2009-09-29 12:20 .fontconfig
drwx------ 4 gdm gdm 4096 2009-10-04 10:40 .gconf
drwx------ 2 gdm gdm 4096 2009-10-04 10:40 .gconfd
drwxr-xr-x 2 gdm gdm 4096 2009-10-04 11:08 .gconf.mandatory
-rw-r--r-- 1 gdm gdm 276 2009-10-03 09:28 .gconf.path
d????????? ? ? ? ? ? .gvfs
-rw-r--r-- 1 gdm gdm 1 2009-10-04 11:15 .gvfs:
-rw------- 1 gdm gdm 15500 2009-10-04 10:40 .ICEauthority
drwxr-xr-x 2 gdm gdm 4096 2009-10-04 10:33 .icons
drwx------ 2 gdm gdm 4096 2009-10-04 10:18 .pulse
-rw------- 1 gdm gdm 256 2009-09-21 20:51 .pulse-cookie
drwxr-xr-x 2 gdm gdm 4096 2009-10-04 10:33 .themes
drwx------ 4 gdm gdm 4096 2009-10-04 10:33 .thumbnails

to do prawidłowego zaktualizowania systemu będziemy musieli wydać parę poleceń :
# umount /var/lib/gdm/.gvfs
# chmod 777 /var/lib/gdm/.gvfs
# apt-get install -f

a na koniec dla pewności można wklepać :
# apt-get update
# apt-get dist-upgrade

 
Dodaj komentarz

Opublikował/a w dniu Październik 4, 2009 w ubuntu

 

Tagi:

Skomentuj

Wprowadź swoje dane lub kliknij jedną z tych ikon, aby się zalogować:

Logo WordPress.com

Komentujesz korzystając z konta WordPress.com. Log Out / Zmień )

Zdjęcie z Twittera

Komentujesz korzystając z konta Twitter. Log Out / Zmień )

Facebook photo

Komentujesz korzystając z konta Facebook. Log Out / Zmień )

Google+ photo

Komentujesz korzystając z konta Google+. Log Out / Zmień )

Connecting to %s

 
%d bloggers like this: